Credit card payment syncs are failing for some QBO customers

Incident Report for Rutter

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 19:09 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 08, 2026 - 16:49 UTC

Investigating

Credit card payment syncs are failing for some QBO customers. Our engineering team is currently investigating.
Posted Jul 08, 2026 - 15:59 UTC
This incident affected: Rutter Data Fetching System.