Continued AWS outages

Incident Report for Rutter

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 16:02 UTC

Monitoring

AWS has resolved the issues in US-EAST-1 and our services are coming back online. We are continuing to monitor.
Posted Oct 20, 2025 - 23:15 UTC

Update

AWS has acknowledged the issues, and are working on it.
Posted Oct 20, 2025 - 20:24 UTC

Identified

Some offline jobs are delayed due to continuing issues with AWS. Customers may experience delays in Syncs and other jobs.
Posted Oct 20, 2025 - 15:39 UTC
This incident affected: Rutter APIs, Rutter Dashboard, Rutter Data Fetching System, and Webhook Delivery.