Wix delays in incremental sync

Incident Report for Rutter

Resolved

Wix incremental syncs are working as expected.
Posted Apr 16, 2025 - 16:27 UTC

Identified

The platform Wix is currently experiencing delays in incremental sync. We have identified the issue and are working on a fix.
Posted Apr 16, 2025 - 14:46 UTC
This incident affected: Rutter APIs.