Delayed request and webhook logs

Incident Report for Rutter

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 18:35 UTC

Monitoring

We're seeing improved performance in the dashboard for sync history, request and webhook logs. We'll continue to monitor the issue.
Posted Oct 28, 2025 - 21:44 UTC

Identified

The team identified an internal migration consuming additional load on our database. We've made changes to relieve the affected resources and will continue to monitor performance.
Posted Oct 28, 2025 - 20:21 UTC

Investigating

Customers are observing delays when receiving webhooks, webhook logs, and request logs. We are actively investigating this issue.
Posted Oct 28, 2025 - 17:13 UTC
This incident affected: Rutter Dashboard and Webhook Delivery.